This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy

Security Advisory - Sudo Privilege Escalation Vulnerability

  • SA No:huawei-sa-20210310-01-escalation
  • Initial Release Date: Mar 10, 2021
  • Last Release Date: Apr 07, 2021

A heap-based buffer overflow vulnerability was found in the way sudo parses command line arguments. This flaw is exploitable by any authenticated, local user who can execute the sudo command. Successful exploitation of this flaw could lead to privilege escalation. (Vulnerability ID: HWPSIRT-2021-11969)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2021-3156.

Huawei has released software updates to fix this vulnerability. This advisory is available at the following link:

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20210310-01-escalation-en

Product Name

Affected Version

Resolved Product and Version

Agile Controller-Campus

V100R003C50SPC302

V100R003C60CP0001

V100R003C60SPC200

V100R003C60SPC201

V100R003C60SPC202

V100R003C60SPC203

V100R003C60SPC205

V100R003C60SPC206

V100R003C60SPC207

V100R003C60SPC208

V100R003C60SPC209

V100R003C60SPC210

V100R003C60SPC211

V100R003C60SPC212

Agile Controller-DCN

V300R003C00

V300R003C00CP3181

V300R003C10SPC200

V300R019C00SPC511

V300R019C00SPC500

V300R019C00SPC501

V300R019C00SPC502

V300R019C00SPC506

V300R019C00SPC507

V300R019C00SPC508

C30

V300R019C60

HoloSens SDC 8.0.2.SPC111

CloudCampus@AC-Campus

19.0.3.2

V300R019C00CP3006

3.1.0

V300R003C10CP6001

3.1.2

V300R019C00CP3006

3.1.3

3.1.5

V300R003C10

V300R003C10CP6001

V300R019C00CP3005

V300R019C00CP3006

V300R019C00SPC200

V300R019C00SPC300

V300R019C00SPC301

V300R019C00SPC310

V300R019C00SPC320

V300R019C00SPC321

FusionDirector

1.5.2

1.6.3.SPC1

1.5.2.SPC3

1.5.2.SPC5

1.6.0

1.6.0.SPC1

1.6.1

1.6.1.SPC1

1.6.1.SPC2

1.6.2

1.6.2.SPC2

1.6.3

FusionSphere OpenStack

6.5.1

6.5.1.HP12

8.0.1

8.0.3

8.0.2

V100R006C00

NFV_FusionSphere 6.5.1.SPC29 or latest version

V100R006C00RC1

V100R006C00U1

V100R006C10

V100R006C30

ManageOne

6.5.0

6.5.1.SPC206

8.0.0

8.0.0-LCN080

8.0.0-LCND81

8.0.1

8.0.2

8.0.2RC1

8.0.3

8.0.3RC1

8.0.RC2

8.0.RC3

NFV_FusionSphere

6.5.1.SPC28

6.5.1.SPC29

8.0.0.SPC15

8.0.0.SPC17

SD-WAN@AC-Campus

V300R003C00SPC600

V300R003C00SPC710

V300R003C00SPC700

V300R019C00

V300R019C00SPC315

SMC2.0

V600R006C00SPC700

V600R019C10SPCa20

V600R006C00SPC800

V600R006C10SPC500

V600R006C10SPC600

V600R006C10SPC601

V600R006C10SPC602

V600R006C10SPC700

V600R019C00

V600R019C10

eSE620X vESS

V100R001C20SPC300

CGP TOOL V100R001C00SPC031

V200R001C00SPC300

iManager NetEco

V600R009C00

V600R009C10CP2004

V600R009C10SPC200

iManager NetEco 6000

V600R008C10SPC300

V600R008C10SPC590

V600R008C20

iMaster NCE-CampusInsight

V100R019C10

V100R019C10CP3021

V100R020C00

V100R020C00CP1031

iMaster NCE-Fabric

V100R019C10CP2061

V100R019C10CP2091

V100R019C10SPC200

V100R019C10SPC201

V100R019C10SPC202

V100R019C10SPC203

V100R019C10SPC206

V100R019C10SPC207

V100R019C10SPC208

V100R019C10SPC209

iMaster NCE-FabricInsight

V100R019C10

V100R019C10CP2071

V100R020C00

V100R020C00CP1032

iMaster NCE-WAN

V100R019C10SPC200

V100R019C10SPC208

V100R019C10SPC201

V100R019C10SPC203

V100R019C10SPC205

V100R019C10SPC207



Successful exploitation of this vulnerability could lead to privilege escalation.

The vulnerability classification has been performed by using the CVSSv3 scoring system (http://www.first.org/cvss/specification-document).

Base Score:7.8(AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)

Temporal Score: 7.0 (E:P/RL:O/RC:C)


This vulnerability can be exploited only when the following conditions are present:

The authenticated, local users could gain access to the affected device.

Vulnerability details:

A heap-based buffer overflow vulnerability was found in the way sudo parses command line arguments. This flaw is exploitable by any authenticated, local user who can execute the sudo command. Successful exploitation of this flaw could lead to privilege escalation.

Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/psirt/report-vulnerabilities.

This vulnerability was publicly disclosed.


2021-04-07 V1.4 UPDATED Updated the "Software Versions and Fixes" section;

2021-03-31 V1.3 UPDATED Updated the "Software Versions and Fixes" section;

2021-03-24 V1.2 UPDATED Updated the "Software Versions and Fixes" section;

2021-03-17 V1.1 UPDATED Updated the "Software Versions and Fixes" section;

2021-03-10 V1.0 INITIAL



Huawei adheres to protecting the ultimate interests of users with best efforts and the principle of responsible disclosure and deal with product security issues through our response mechanism.

To enjoy Huawei PSIRT services and obtain Huawei product vulnerability information, please visit http://www.huawei.com/en/psirt.

To report a security vulnerability in Huawei products and solutions, please send it to PSIRT@huawei.com. For details, please visit http://www.huawei.com/en/psirt/report-vulnerabilities.

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.