This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our private policy>

Security Advisory - Buffer Overflow Vulnerability in Some Huawei Products

  • SA No:huawei-sa-20171206-01-buffer
  • Initial Release Date: Dec 06, 2017
  • Last Release Date: Dec 28, 2017

There is a buffer overflow vulnerability in the Common Open Policy Service Protocol (COPS) module of some Huawei products. An unauthenticated, remote attacker could exploit this vulnerability by sending specially crafted message to the affected products. The vulnerability is due to insufficient input validation of the message, which could result in a buffer overflow. Successful exploit may cause some services abnormal. (Vulnerability ID: HWPSIRT-2017-04072)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-15350.

Huawei has released software updates to fix this vulnerability. This advisory is available at the following link:

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20171206-01-buffer-en

Product Name

Affected Version

Resolved Product and Version

DP300

V500R002C00

V500R002C00SPCb00

IPS Module

V100R001C10

Upgrade to V500R001C60SPC300 + V500R001SPH012

V100R001C20

V100R001C30

V500R001C00

V500R001C20

V500R001C30

V500R001C50

NGFW Module

V100R001C10

Upgrade to V500R001C60SPC300 + V500R001SPH012

V100R001C20

V100R001C30

V500R001C00

V500R001C20

NIP6300

V500R001C00

Upgrade to V500R001C60SPC300 + V500R001SPH012

V500R001C20

V500R001C30

V500R001C50

NIP6600

V500R001C00

Upgrade to V500R001C60SPC300 + V500R001SPH012

V500R001C20

V500R001C30

V500R001C50

NIP6800

V500R001C50

Upgrade to V500R001C60SPC300 + V500R001SPH012

RP200

V500R002C00

Upgrade to TEX0[1] V600R006C00SPC400

V600R006C00

TEX0[1] V600R006C00SPC400

SVN5600

V200R003C00

Upgrade to V200R003C10SPCa00

V200R003C10

V200R003C10SPCa00

SVN5800

V200R003C00

Upgrade to V200R003C10SPCa00

V200R003C10

V200R003C10SPCa00

SVN5800-C

V200R003C00

Upgrade to V200R003C10SPCa00

V200R003C10

V200R003C10SPCa00

Secospace USG6300

V100R001C10

Upgrade to V500R001C60SPC300 + V500R001SPH012

V100R001C20

V100R001C30

V500R001C00

V500R001C20

V500R001C30

V500R001C50

Secospace USG6500

V100R001C10

Upgrade to V500R001C60SPC300 + V500R001SPH012

V100R001C20

V100R001C30

V500R001C00

V500R001C20

V500R001C30

V500R001C50

Secospace USG6600

V100R001C00

Upgrade to V500R001C60SPC300 + V500R001SPH012

V100R001C20

V100R001C30

V500R001C00

V500R001C20

V500R001C30

V500R001C50

TE30

V100R001C02

Upgrade to TEX0[1] V600R006C00SPC400

V100R001C10

V500R002C00

V600R006C00

TEX0[1] V600R006C00SPC400

TE40

V500R002C00

Upgrade to TEX0[1] V600R006C00SPC400

V600R006C00

TEX0[1] V600R006C00SPC400

TE50

V500R002C00

Upgrade to TEX0[1] V600R006C00SPC400

V600R006C00

TEX0[1] V600R006C00SPC400

TE60

V100R001C01

Upgrade to TEX0[1] V600R006C00SPC400

V100R001C10

V500R002C00

V600R006C00

TEX0[1] V600R006C00SPC400

TP3206

V100R002C00

V100R002C00SPC800

V100R002C10

USG9500

V500R001C00

Upgrade to V500R001C60SPC300 + V500R001SPH012

V500R001C20

V500R001C30

V500R001C50

Note:

[1] RP200, TE30, TE40, TE50,TE60 and TX50 are included in the TEX0 software package.

Successful exploit may cause some service abnormal.

The vulnerability classification has been performed by using the CVSSv3 scoring system (http://www.first.org/cvss/specification-document).

Base Score: 5.3 (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)

Temporal Score: 4.9 (E:F/RL:O/RC:C)

This vulnerability can be exploited only when the following conditions are present:

1. The attacker can connect to the network of the affected products.

Vulnerability details:

An unauthenticated, remote attacker could exploit this vulnerability by sending specially crafted message to the affected products. The vulnerability is due to insufficient input validation of the message, which could result in a buffer overflow. Successful exploit may cause some services abnormal.

Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/psirt/report-vulnerabilities.

This vulnerability was discovered by Huawei internal tester.

2017-12-28 V1.1 UPDATED Updated the "Software Versions and Fixes" section;

2017-12-06 V1.0 INITIAL

Huawei adheres to protecting the ultimate interests of users with best efforts and the principle of responsible disclosure and deal with product security issues through our response mechanism.

To enjoy Huawei PSIRT services and obtain Huawei product vulnerability information, please visit http://www.huawei.com/en/psirt.

To report a security vulnerability in Huawei products and solutions, please send it to PSIRT@huawei.com. For details, please visit http://www.huawei.com/en/psirt/report-vulnerabilities.

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.