This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our private policy>

Security Advisory - Multiple Vulnerabilities in FusionSphere OpenStack

  • SA No:huawei-sa-20171018-01-fusionsphere
  • Initial Release Date: 2017-10-18
  • Last Release Date: 2017-11-16

There is a command injection vulnerability in Huawei FusionSphere OpenStack. Due to lack of validation, an attacker with high privilege may inject malicious code into some module of the affected products, causing code execution. (Vulnerability ID: HWPSIRT-2017-07055)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-8188.

There is a path traversal vulnerability in Huawei FusionSphere OpenStack. Due to insufficient path validation, an attacker with high privilege may exploit this vulnerability to cover some files, causing services abnormal. (Vulnerability ID: HWPSIRT-2017-07056)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-8189.

There is an improper verification of cryptographic signature vulnerability in Huawei FusionSphere OpenStack. The software does not verify the cryptographic signature. An attacker with high privilege may exploit this vulnerability to inject malicious software. (Vulnerability ID: HWPSIRT-2017-07057)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-8190.

There is a week cryptographic algorithm vulnerability in Huawei FusionSphere OpenStack. Attackers may exploit the vulnerability to crack the cipher text and cause information leak on the transmission links. (Vulnerability ID: HWPSIRT-2017-07058)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-8191.

Huawei has released software updates to fix these vulnerabilities. This advisory is available at the following link:

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20171018-01-fusionsphere-en

Product Name

Affected Version

Resolved Product and Version

FusionSphere OpenStack

V100R006C00SPC102(NFV)

Upgrade to V100R006C10SPC300

HWPSIRT-2017-07055:

An attacker could exploit this vulnerability to cause code execution.

HWPSIRT-2017-07056:

An attacker may exploit this vulnerability to cover some files, causing services abnormal.

HWPSIRT-2017-07057:

An attacker may exploit this vulnerability to inject malicious software.

HWPSIRT-2017-07058:

Successful exploit may cause information leak.

The vulnerability classification has been performed by using the CVSSv3 scoring system (http://www.first.org/cvss/specification-document).

HWPSIRT-2017-07055:

Base Score: 4.7 (AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L)

Temporal Score: 4.4 (E:F/RL:O/RC:C)

HWPSIRT-2017-07056:

Base Score: 6.0 (AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H)

Temporal Score: 5.6 (E:F/RL:O/RC:C)

HWPSIRT-2017-07057:

Base Score: 6.7 (AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H)

Temporal Score: 6.2 (E:F/RL:O/RC:C)

HWPSIRT-2017-07058:

Base Score: 3.7 (AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)

Temporal Score: 3.5 (E:F/RL:O/RC:C)

HWPSIRT-2017-07055:

This vulnerability can be exploited only when the following conditions are present:

1. An attacker gains access of the affected products.

Vulnerability details:

Due to lack of validation, an attacker with high privilege may inject malicious code into some module of the affected products, causing code execution.

HWPSIRT-2017-07056:

This vulnerability can be exploited only when the following conditions are present:

1. An attacker gains access of the affected products.

Vulnerability details:

Due to insufficient path validation, an attacker with high privilege may exploit this vulnerability to cover some files, causing services abnormal.

HWPSIRT-2017-07057:

This vulnerability can be exploited only when the following conditions are present:

1. An attacker gains access of the affected products.

Vulnerability details:

The software does not verify the cryptographic signature. An attacker with high privilege may exploit this vulnerability to inject malicious software.

HWPSIRT-2017-07058:

This vulnerability can be exploited only when the following conditions are present:

1. An attacker gains access of the affected products.

Vulnerability details:

Attackers may exploit the vulnerability to crack the cipher text and cause information leak on the transmission links.

Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/psirt/report-vulnerabilities.

This vulnerability was discovered by Huawei internal tester.

2017-11-16 V1.2 UPDATE Update vulnerability information

2017-11-10 V1.1 UPDATE Update the affected product list

2017-10-18 V1.0 INITIAL

Huawei adheres to protecting the ultimate interests of users with best efforts and the principle of responsible disclosure and deal with product security issues through our response mechanism.

To enjoy Huawei PSIRT services and obtain Huawei product vulnerability information, please visit http://www.huawei.com/en/psirt.

To report a security vulnerability in Huawei products and solutions, please send it to PSIRT@huawei.com. For details, please visit http://www.huawei.com/en/psirt/report-vulnerabilities.

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.