This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our private policy>

Security Advisory - DoS Vulnerability in GPU Driver of Huawei Products

  • SA No:Huawei-SA-20151106-01-GPU
  • Initial Release Date: 2015-11-06
  • Last Release Date: 2015-11-06

Some Huawei products have a DoS vulnerability. An attacker may trick a user into installing a malicious application and use it to input invalid parameters into the GPU driver program of the products, which can crash the system of the device. (Vulnerability ID: HWPSIRT-2015-09017)

 

This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) ID: CVE-2015-7740.

 

Huawei has released software updates to fix these vulnerabilities. This advisory is available at the following link:
http://www.huawei.com/en/security/psirt/security-bulletins/security-advisories/hw-460486.htm

Product Name

Affected Version

Resolved Product and Version

P7

Versions earlier than P7-L00C17B851

P7-L00C17B851

Versions earlier than P7-L05C00B851

P7-L05C00B851

Versions earlier than P7-L09C92B851

P7-L09C92B851

P8 ALE-UL00

Versions earlier than ALE-UL00B211

ALE-UL00B211

[1] Mobile phones will receive a system update prompt. The vulnerabilities will be fixed after users install the update.


An attacker may exploit this vulnerability to crash the system of the device.

The vulnerability classification has been performed by using the CVSSv2 scoring system (http://www.first.org/cvss/).

Base Score: 4.0 (AV:L/AC:H/Au:N/C:N/I:N/A:C)

Temporal Score: 3.3 (E:F/RL:OF/RC:C)

1. Prerequisite:

The attacker successfully tricks a user into installing a malicious application on the device.

2. Attacking procedure:

The attacker tricks a user into installing a malicious application on the device. The malicious application can access specific GPU driver interfaces of the products by system calls. The GPU driver improperly handles the invalid parameters input by the application. Therefore, the attacker may exploit this vulnerability to input invalid parameters, which can crash the system of the device.

1. Mobile phones that support automatic update will receive a system update prompt. You can install the update to fix the vulnerabilities.

2. Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/security/psirt/report-vulnerabilities/index.htm.


This vulnerability was found by Gengjia Chen (@jiayy) of Lab 0x031E of Qihoo 360 Technology Co. Ltd. Huawei PSIRT is not aware of malicious use of the vulnerability described in this advisory.

Huawei express our appreciation for Gengjia Chen’s concerns on Huawei products.

For security problems about Huawei products and solutions, please contactPSIRT@huawei.com.

For general problems about Huawei products and solutions, please directly contact Huawei TAC (Huawei Technical Assistance Center) to request the configuration or technical assistance.


2015-11-06 V1.0 INITIAL
This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.


Complete information for providing feedback on security vulnerability of Huawei products, getting support for Huawei security incident response services, and obtaining Huawei security vulnerability information, is available on Huawei's worldwide website at http://www.huawei.com/en/security/psirt/.