This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy (update in May 2018) >

Security Advisory-Apache Struts2 vulnerability on Huawei multiple products

  • SA No:Huawei-SA-20140707-01-Struts2
  • Initial Release Date: Jul 07, 2014
  • Last Release Date: Jul 08, 2014

Some versions of Apache Struts2 software used in Huawei devices have security vulnerabilities. A patch released for the software to fix vulnerabilities CVE-2014-0050 and CVE-2014-0094 has the risk of being bypassed. (Vulnerability ID: HWPSIRT-2014-0420)

This Vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) ID: CVE-2014-0116.

By exploiting this vulnerability, attackers can bypass the patch and cause file disclosure or DoS, or remotely execute arbitrary commands in some specific situations. 

The vulnerability classification has been performed by using the CVSSv2 scoring system (http://www.first.org/cvss/).

Base Score: 5.8 (AV:N/AC:M/Au:N/C:N/I:P/A:P)

Temporal Score: 4.8 (E:F/RL:O/RC:C)

For additional details, customers are advised to reference the Apache Struts2 Project security bulletins:

http://struts.apache.org/release/2.3.x/docs/s2-022.html

Upgrading version and version status:

Product Name

Affected Version

Solved version

AnyOffice

V200R002C10SPC500

V200R002C10L00422

eSpace Meeting Portal

V100R001C00

V100R001C00SPC303

Eudemon8000E-X3/ X8/ X16
USG9520/ USG9560/ USG9580

V200R001C00

AntiDDoS 8000 V100R001C00SPH503

AntiDDoS 8030/ 8060/ 8080
AntiDDoS 1520/ 1550/ 500-D

V100R001C00

 

Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades, or obtain them through Huawei worldwide website at http://support.huawei.com/support/. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/security/psirt/report-vulnerabilities/index.htm.


This vulnerability is disclosed by Apache Struts2 team. Huawei PSIRT is not aware of any public announcements or malicious use of the vulnerability described in this advisory.

For security problems about Huawei products and solutions, please contact PSIRT@huawei.com.

For general problems about Huawei products and solutions, please directly contact Huawei TAC (Huawei Technical Assistance Center) to request the configuration or technical assistance.


2014-07-08 V1.1 UPDATED Update the Software Versions and Fixes

2014-07-07 V1.0 INITIAL

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.


Complete information on providing feedback on security vulnerability of Huawei products, getting support for Huawei security incident response services, and obtaining Huawei security vulnerability information, is available on Huawei's worldwide website at http://www.huawei.com/en/security/psirt/.