This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy (update in May 2018) >

Security Advisory - Multiple Vulnerabilites in SIP Module on Huawei Products

  • SA No:huawei-sa-20171206-01-sip
  • Initial Release Date: Dec 06, 2017
  • Last Release Date: Dec 06, 2017

There is an overflow vulnerability on the SIP module that attacker can exploit by sending a specially crafted SIP message, leading to a process reboot at random. (Vulnerability ID: HWPSIRT-2017-06044) 

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-17142.


There is an overflow vulnerability on the SIP module that the module cannot parse a malformed SIP message when validating variables. Attacker can exploit it to make one process reboot at random. (Vulnerability ID: HWPSIRT-2017-06045)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-17143.


There is an overflow vulnerability on the Backup feature of SIP module when the module process a specific amount of state. The module cannot handle it, causing SIP module DoS. (Vulnerability ID: HWPSIRT-2017-06046)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2017-17144.


Huawei has released software updates to fix these vulnerabilities. This advisory is available at the following link:

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20171206-01-sip-en

Product Name

Affected Version

Resolved Product and Version

DP300

V500R002C00

V500R002C00SPCb00

V500R002C00SPC100

V500R002C00SPC200

V500R002C00SPC300

V500R002C00SPC400

V500R002C00SPC500

V500R002C00SPC600

V500R002C00SPC800

V500R002C00SPC900

V500R002C00SPCa00

RP200

V500R002C00SPC200

Upgrade to TEX0 V600R006C00SPC400

V600R006C00

TEX0 V600R006C00SPC400

V600R006C00SPC200

RSE6500

V500R002C00SPC100

V500R002C00SPC800

V500R002C00SPC200

V500R002C00SPC300

V500R002C00SPC300T

V500R002C00SPC500

V500R002C00SPC600

V500R002C00SPC700

V500R002C00T

TE30

V100R001C10

Upgrade to TEX0 V600R006C00SPC400

V100R001C10SPC100

V100R001C10SPC200B010

V100R001C10SPC300

V100R001C10SPC500

V100R001C10SPC600

V100R001C10SPC700B010

V100R001C10SPC800

V500R002C00SPC200

V500R002C00SPC500

V500R002C00SPC600

V500R002C00SPC700

V500R002C00SPC900

V500R002C00SPCb00

V600R006C00

TEX0 V600R006C00SPC400

TE40

V500R002C00SPC600

Upgrade to TEX0 V600R006C00SPC400

V500R002C00SPC700

V500R002C00SPC900

V500R002C00SPCb00

V600R006C00

TEX0 V600R006C00SPC400

V600R006C00SPC200

TE50

V500R002C00SPC600

Upgrade to TEX0 V600R006C00SPC400

V500R002C00SPC700

V500R002C00SPCb00

V600R006C00

TEX0 V600R006C00SPC400

V600R006C00SPC200

TE60

V100R001C01SPC100

Upgrade to TEX0 V600R006C00SPC400

V100R001C01SPC107TB010

V100R001C10

V100R001C10SPC300

V100R001C10SPC400

V100R001C10SPC500

V100R001C10SPC600

V100R001C10SPC700

V100R001C10SPC800

V100R001C10SPC900

V500R002C00

V500R002C00SPC100

V500R002C00SPC200

V500R002C00SPC300

V500R002C00SPC600

V500R002C00SPC700

V500R002C00SPC800

V500R002C00SPC900

V500R002C00SPCa00

V500R002C00SPCb00

V500R002C00SPCd00

V600R006C00

TEX0 V600R006C00SPC400

V600R006C00SPC100

V600R006C00SPC200

V600R006C00SPC300

TP3106

V100R002C00

TP3206 V100R002C00SPC800

V100R002C00SPC200

V100R002C00SPC400

V100R002C00SPC600

V100R002C00SPC700

V100R002C00SPC800

TP3206

V100R002C00

V100R002C00SPC800

V100R002C00SPC200

V100R002C00SPC400

V100R002C00SPC600

V100R002C00SPC700

V100R002C10

ViewPoint 9030

V100R011C02SPC100

Upgrade to V100R011C03SPC800

V100R011C03B012SP15

V100R011C03SPC800

V100R011C03B012SP16

V100R011C03B015SP03

V100R011C03LGWL01SPC100

V100R011C03SPC100

V100R011C03SPC200

V100R011C03SPC300

V100R011C03SPC400

V100R011C03SPC500

eSpace U1960

V200R003C30SPC200

eSpace U1981 V200R003C30SPC500

eSpace U1981

V100R001C20SPC700

Upgrade to V200R003C30SPC500

V200R003C20SPCa00


HWPSIRT-2017-06044:

Attackers can exploit the vulnerability to cause one process of SIP module reboot.

HWPSIRT-2017-06045:

Attackers can exploit the vulnerability to cause one process of SIP module reboot.

HWPSIRT-2017-06046:

Attackers can exploit the vulnerability to cause Backup feature of SIP module DoS.


The vulnerability classification has been performed by using the CVSSv3 scoring system (http://www.first.org/cvss/specification-document).

HWPSIRT-2017-06044:

Base Score: 5.3 (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)

Temporal Score: 4.8 (E:F/RL:O/RC:C)

HWPSIRT-2017-06045:

Base Score: 5.3 (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)

Temporal Score: 4.8 (E:F/RL:O/RC:C)

HWPSIRT-2017-06046:

Base Score: 5.3 (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)

Temporal Score: 4.8(E:F/RL:O/RC:C)

HWPSIRT-2017-06044:

This vulnerability can be exploited only when the following conditions are present:

1 Attackers have access to the network using SIP

Vulnerability details:

Attacker can exploit by sending a specially crafted SIP message, leading to a process reboot.

HWPSIRT-2017-06045:

This vulnerability can be exploited only when the following conditions are present:

1 Attackers have access to the network using SIP

Vulnerability details:

The module cannot parse a malformed SIP message when validating variables. Attacker can exploit it to make one process reboot.

HWPSIRT-2017-06046:

This vulnerability can be exploited only when the following conditions are present:

1 Attackers have access to the network using SIP

Vulnerability details:

There is an overflow vulnerability on the Backup feature of SIP module when the module process a specific amount of state. The module cannot handle it, causing SIP module DoS.


Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/psirt/report-vulnerabilities.

These vulnerabilities were discovered by Huawei internal tester.

2017-12-06 V1.0 INITIAL

Huawei adheres to protecting the ultimate interests of users with best efforts and the principle of responsible disclosure and deal with product security issues through our response mechanism.

To enjoy Huawei PSIRT services and obtain Huawei product vulnerability information, please visit http://www.huawei.com/en/psirt.

To report a security vulnerability in Huawei products and solutions, please send it to PSIRT@huawei.com. For details, please visit http://www.huawei.com/en/psirt/report-vulnerabilities.

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.