This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our private policy>

Security Advisory - Two Buffer Overflow Vulnerabilities in the GaussDB

  • SA No:huawei-sa-20170607-01-gaussdb
  • Initial Release Date: 2017-06-07
  • Last Release Date: 2017-11-10

GaussDB has a buffer overflow vulnerability. An authenticated, remote attacker could use a specially crafted string in an SQL query to cause the database to crash, or lead to privilege escalation. (Vulnerability ID: HWPSIRT-2017-05016)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2015-0242.

GaussDB has a buffer overflow vulnerability. An authenticated, remote attacker could craft a specific SQL query to cause the database to crash. (Vulnerability ID: HWPSIRT-2017-06025)

This vulnerability has been assigned a Common Vulnerabilities and Exposures (CVE) ID: CVE-2015-3166.

Huawei has released software updates to fix these vulnerabilities. This advisory is available at the following link:

http://www.huawei.com/en/psirt/security-advisories/huawei-sa-20170607-01-gaussdb-en

Product Name

Affected Version

Resolved Product and Version

FusionSphere OpenStack

V100R005C00

Upgrade to V100R006C10

V100R005C10

V100R006C00SPC102(NFV)

HWPSIRT-2017-05016:

An attacker could exploit the vulnerability to cause the database to crash, or lead to privilege escalation.

HWPSIRT-2017-06025:

An attacker could exploit the vulnerability to cause the database to crash.

The vulnerability classification has been performed by using the CVSSv3 scoring system (http://www.first.org/cvss/specification-document).

HWPSIRT-2017-05016:

Base Score: 6.3 (AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L)

Temporal Score: 5.9 (E:F/RL:O/RC:C)

HWPSIRT-2017-06025:

Base Score: 4.3 (AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L)

Temporal Score: 4.0 (E:F/RL:O/RC:C)

HWPSIRT-2017-05016:

This vulnerability can be exploited only when the following conditions are present:

1. An attacker could access the GaussDB.

Vulnerability details:

An authenticated, remote attacker could use a specially crafted string in an SQL query to cause the database to crash, or lead to privilege escalation.

HWPSIRT-2017-06025:

This vulnerability can be exploited only when the following conditions are present:

1. An attacker could access the GaussDB.

Vulnerability details:

An authenticated, remote attacker could craft a specific SQL query to cause the database to crash.

Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades. For TAC contact information, please refer to Huawei worldwide website at http://www.huawei.com/en/psirt/report-vulnerabilities.

These vulnerability were discovered by Huawei internal tester.

2017-11-10 V1.1 UPDATE Update the affected product list

2017-06-07 V1.0 INITIAL

Huawei adheres to protecting the ultimate interests of users with best efforts and the principle of responsible disclosure and deal with product security issues through our response mechanism.

To enjoy Huawei PSIRT services and obtain Huawei product vulnerability information, please visit http://www.huawei.com/en/psirt.

To report a security vulnerability in Huawei products and solutions, please send it to PSIRT@huawei.com. For details, please visit http://www.huawei.com/en/psirt/report-vulnerabilities.

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.