This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our private policy>

Security Advisory - Huawei VSM Default User Groups’ Privilege Escalation

  • SA No:Huawei-SA-20130403-01-VSM
  • Initial Release Date: 2013-04-03
  • Last Release Date: 2013-04-20

VSM (Versatile Security Manager) is a unified security service management system launched by Huawei for carrier and enterprise customers.

VSM contains a vulnerability that default user groups’ privilege could be escalated when one user logs in to the system to modify default user groups’ permission configurations. The vulnerability is due to improper validation of authentication to the accessed user account (Vulnerability ID: HWNSIRT-2013-0302).

Currently, the official version VSM V200R002C00SPC300 has been released to fix this vulnerability.

Product Name

Affected Version

Resolved Product and Version

Seco VSM





By exploiting the vulnerability successfully, it may cause the privilege escalation of VSM default user groups, and then users in the user group could operate the system without authentication.

The vulnerability classification has been performed by using the CVSSv2 scoring system (

The score of the vulnerability is following:

Base Score: 9.0(AV:N/AC:L/Au:S/C:C/I:C/A:C)

Temporal Score: 7.5 (E:F/RL:O/RC:C)

Overall Score: 7.5

Vulnerability exploitation prerequisites:

The attacker can access VSM system,

The attacker has VSM user account and password.


Vulnerability details:

Any user in the VSM default user groups can change default groups’ privilege configuration without specific authentication after it logs in to the VSM system, and then it may cause the privilege escalation of the default user group in VSM.

Customers should contact Huawei TAC (Huawei Technical Assistance Center) to request the upgrades, or obtain them through Huawei Enterprise worldwide website at For TAC contact information, please refer to Huawei worldwide website at


The link for VSM V200R002C00SPC300:|7919710|9856717|7923123|9858904|8577742&pid=8577742&vrc=8616279|8616281|8616284|9470142&show=showVDetail&tab=bz&bz_vr=8616281&bz_vrc=&nbz_vr=null

This vulnerability is reported by Huawei internal tester and hasn’t received any impact report. Huawei PSIRT is not aware of any malicious use launched to attack through the vulnerability described in this advisory.

For security problems about Huawei products and solutions, please

For general problems about Huawei products and solutions, please directly contact Huawei TAC (Huawei Technical Assistance Center) to request the configuration or technical assistance.

2013-04-03 V1.0 INITIAL

2013-04-20 V1.1 UPDATED update CVSS score

This document is provided on an "AS IS" basis and does not imply any kind of guarantee or warranty, either express or implied, including the warranties of merchantability or fitness for a particular purpose. In no event shall Huawei or any of its directly or indirectly controlled subsidiaries or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages. Your use of the document, by whatsoever means, will be totally at your own risk. Huawei is entitled to amend or update this document from time to time.

Complete information for providing feedback on security vulnerability of Huawei products, getting support for Huawei security incident response services, and obtaining Huawei security vulnerability information, is available on Huawei's worldwide website at